Solution for the : Error while installing Prophet library on Windows Machine

I’m trying to install fbprophet using pip on windows10 and the following error is showed

— — — — — — — — — — — — — — — — — -

Prophet is a forecasting procedure implemented in R and Python. It is fast and provides completely automated forecasts that can be tuned by hand by data scientists and analysts.

I have the pystan packet already installed

The log image asked by phd

Solution:

I tried many solutions to resolve this issue but lot of time I used to be fade up by Googling and trying out multiple solutions and not yet working with the Prophet library.

I do even tried using the Google Colab platform to run my project work, but there I was popped up and restricted by the errors thrown due to use of Dash in the Python-based Flask Web App.

Finally after lot of struggle and multiple to-and-fro trial-and-error solutions,
I came out with the below steps of solutions which helped me out to complete my final end of the project work I was expected to carry out for my Machine Learning Model build out on the Flask based Web Application in Dask framework.

I had faced same problem. I used “conda” rather than “pip” for installation with steps shown below and it worked magical for me.

Now you can go ahead with : “from fbprophet import Prophet” in python environment.

Young budding Professional Graduate Student interested in Cloud Computing and Big Data Processing and Optimization.